Account Reporting and Payments Delayed: Nordea

Incident Report for Atlar

Resolved

Technical issues at Nordea resolved.
Posted Oct 03, 2024 - 11:15 UTC

Update

We are continuing to investigate this issue.
Posted Oct 03, 2024 - 10:08 UTC

Investigating

Delay in delivery of Corporate Access account intraday reports and execution of Payments due to technical issues at Nordea.
Posted Oct 03, 2024 - 10:08 UTC
This incident affected: Connectivity (Denmark, Finland, Norway, Sweden).